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REPAIRING PHOTOS AND DOCUMENTS WITH GIMP

Adding photos to your family history documentation makes them much more interesting.  Most of the 
time you will be scanning old photos.  When scanning photos make sure the flat bed is dust free.  Old 
photos produce a lot of dust and that dust will show up in your scans, so make sure to keep your glass 
dust free.  Another tip, is even though the ancient photo will most likely be in black and white, always 
scan your photos in color as you will be able to tease out more details.  

When doing family history you may come across images that are less than ideal.  The image may be 
crooked, faded, or damaged image.  In order to fix these issues you will need some sort of photo editing
software, with more options than MS Photos has to offer.    

We are using GIMP because it is the most powerful free alternative to PhotoShop.

GIMP has a very busy interface because it does so many things.  This booklet covers the some of the 
basic concepts to get started with photo restoration.   The videos have been carefully chosen for pace 
with the 55+ brain in mind.   

GIMP – GNU Image Manipulation Program

There are still some developers who write open source, and then support their products with ads on 
their site and solicit donations if you find their product useful.  You are probably familiar with 
OpenOffice or LibreOffice, which are open source alternatives to Microsoft Office.  Likewise, GIMP is
an open source alternative to Adobe Photoshop.  Adobe is the top of the line photo editing software.  
Adobe has many products that manipulate photos. Photoshop Elements retails for 119, PhotoShop CC 
costs up to $20 a month.  GIMP is a powerful photo editing program that you can download and use for
free.  If you find the program useful, you can make a donation to the developer through the website.

Both GIMP and Adobe Photoshop Elements have an intimidating interface, but the processes I have 
used for photo repair on each piece of software I have used has been about the same degree of 
difficulty.

https://www.gimp.org/
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SETTING UP GIMP ON WINDOWS 10 or 11.

With any open source program you need to make sure you are getting it from the correct website, and 
beware of ads that may masquerade as the official download.  The base GIMP application can be found 
at https://www.gimp.org/

ARTICLE Gimp Add Ons https://www.makeuseof.com/tag/install-gimp-plugins/

In the lab we have these GIMP and these plugins that were recommended by Make Use Of:

GIMP 2.10.8
G'mic (plug-in with great special  effects)
GIMP Scripts Bundle 
Duplicate to Another Image
NIK Collection
Reynthesize (a powerful healing addon, I could only find the Windows version in a blog post)
Wavelet Decompose (powerful add on for working with skin tones) 
Darkroom (for use with .RAW files )
Hugin Panoramas (windows 64 only)

Right click on an image from the file explorer. 
Select Open With 
Choose Set Default
Choose Other
Navigate to “C:\Program Files\GIMP 2\2.1\bin\GIMP 2.10”
Uncheck Always Open With unless you want this to really be the default program.
Repeat these steps for JPG, BMP, PNG, GIF....

PREFERENCES

Initial setup comes with a dark theme and dark icons, and for most of us will need color icons to 
actually differentiate the tools.  First thing to do is visit the Edit → Preferences  menu and change the 
Interface settings :

Theme we are using System Theme
Theme Icon we are using Color Icons
Toolbox  uncheck Use tool groups (not present in 2.10.8, but is present in later versions 

and makes icons harder to find.)
 
FILES

File types
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GIMP handles a large variety of file formats, but as a beginner,  for the most part we will be limiting 
our discussion to XCF, JPG and PNG files.  

• XCF, short for eXperimental Computing Facility, is the native image format of the GIMP 
image-editing program. XCF files are project files.  XCFs save all of the data the program 
handles related to the image, including, among others, each layer, the current selection, 
channels, transparency, paths and guides.  This format is used inside of GIMP and is not 
suitable to share your finished work, instead you will be exporting to JPG or PNG.

• JPG – JPEG, short for Joint Photography Experts Group,  is a format that is the most common
image format used by digital cameras and other photographic image capture devices.  It is the 
most common format for storing and transmitting photographic images on the World Wide Web.
It is a “lossy” format, which means that every time you re-save the image, a little of the quality 
is lost. 

• PNG – Portable Network Graphics that supports lossless data compression.  The PNG format 
was developed for transferring images on the Internet, not for professional-quality print 
graphics.  Export to PNG if you need to preserve transparency in a picture. 

Opening a file in GIMP

The File → Open dialog box in GIMP is quite different than anything I have ever seen on a Windows 
PC.  Watch the video for an excellent demo on the ways to open a file in GIMP.

VIDEO How to open an Image 5:07 https://www.youtube.com/watch?v=Oiyx52f6sp0

Saving a file

The Save and Save As dialog box, allows you to save an XCF file.  If the file has already been named, 
the Save feature will overwrite the previous version without a warning message, otherwise this will 
bring up the Save As dialog..  Use Save As to change the name.  

Exporting a file

The Export and Export As are the options you need to create a picture suitable for sharing or using in 
a document.  To select the JPG or PNG format, merely change the file extension when you specify the 
file name.  If the file was an import, the Export option will be replaces with an Overwrite option.
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Dockable Dialog Boxes

When you first installed GIMP, it was configured to be in Single-Window Mode. There are several tool 
docks on the edges, each with multiple tabs.   But GIMP can be easily customized.   The Docks and 
tabs can be torn off  made to float and can be docked and closed individually.  This is really great if you
are a power user, not so great if you use the software once in a blue moon.  

The docks can easily be restored by going to the Windows menu ,  (see troubleshooting)  but the tabs 
may be missing or moved . 

TOOLS OPTION TAB

The Tools Option Tab is one of the most important dialog boxes.  You need to view it any time you 
change tools.  It is quite easily dislodged from its dock and closed.  While it is easy to get back,   I'd 
suggest beginners  lock the Tools Option menu in place so that its always the first tab under the quick 
tools area.
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SELECTION TOOLS

Selection tools are designed to select regions from the active layer so you can work on them without 
affecting the unselected areas.  

In order to make changes, the area must be selected.  You can use the selection to limit the areas that 
are changed by the various painting tools BucketFill, Gradient, Pencil, Paintbrush, Eraser, Airbrush, 
Ink, Clone, Heal, Perspective Clone, Blur/Sharpen, Smudge, dodge /Burn)

In addition there are more selection tools from the Select menu at the top of the screen.
Select

Select All Ctrl+A
Select None Shift + Ctrl + A
Invert Selection Ctrl + I

GIMP offers advanced users a lot of great selection features by using the modifier keys (combinations 
of ALT, CTRL,  Shift) with the mouse and a lot of keyboard shortcuts.  For now we are sticking with 
the settings we can choose on the screen, but as you do become more proficient, do visit the GIMP help
pages to see these advanced features.
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Selection Mode    

The selection mode on the Tools Option tab determines the way that the selection you create is 
combined with any pre-existing selection. Note that the functions performed by these buttons can be 
duplicated using modifier keys, as described above. For the most part, advanced users use the modifier 
keys; novice users find the mode buttons easier. 

Replace mode will cause any existing selection to be destroyed or replaced when the new 
selection is created. 

 Add mode will cause the new selection to be added to any existing selection regions. 

 Subtract mode will remove the new selection area from any existing selection regions. 

 Intersection mode will make a new selection from the area where the existing selection region 
and the new selection region overlap. 

Antialiasing 

This option only affects some selection tools: it causes the boundary of the selection to be 
drawn more smoothly. 

Feather Edges 

This options allows the boundary of the selection to be blurred, so that points near the boundary 
are only partially selected.

VIDEO Selection 3:23: https://www.youtube.com/watch?v=UfdtI1re3oM
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PAINTING TOOLS

There are fourteen painting tools included in GIMP.  All the paint tools except the Bucket Fill and 
Gradient have a brush size in the Tool Options.  For photo restoration, the clone tool, the heal tool, the 
blur tool, the dodge tool will be the most useful. 

BRUSHES OPTIONS

You'll be using sliders a lot in GIMP.  These work differently than any other slider I have ever 
encountered.  Placement of your pointer is very important when using these sliders.  If you drag the 
slider to adjust the value,  the speed that the slider slides will depend on if you are in the upper or lower
half of the slider.  

TIP SLIDERS TIP
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MODE

Many brushes have a mode drop-down menu available.  I haven't been able
to find a comprehensive list of what these modes are used for, only a few 
of the modes were shown in troubleshooting guides, as to why the tools 
were not working as advertised.

OPACITY

The Opacity slider indicates how sheer or opaque the brush is going to be 
painting.  Even at full opacity some of the tools will be slightly translucent.
If you wanted to paint with nothing showing through choose the right 
painting tool.  Ink will be opaque, while the paintbrush will be translucent.

SIZE

As the name implies, Size allows you to control the size of the area being painted.
Quick tip: instead of moving your mouse over to the tools Option tab, use the brackets [ and ]  from 
the keyboard to get the brush to resize to fit in the area. This method lets you resize brush without 
having to guess at the size.  

ASPECT RATIO and ANGLE

Changing an Aspect Ratio and an angle together make a big difference in a round brush.  The circle had
an aspect ratio of 0.  When we changed it to 12.62 it flattened.  When we change the angle to 42.10 it 
turned on its side.
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If you click on the brush icon it will show you a variety of standard brushes.  The 4 round brushes 
shown here on the second row are the most common.  They vary in hardness.    Use a softer brush to 
make the painting blend better.  

MY PAINT BRUSH – Advanced Topic not covered in class.

This “My Paintbrush” tool is an advanced tool.  You can make your own custom brushes or 
load pre-made brushes.  
VIDEO My Paintbrush 3:21 https://www.youtube.com/watch?v=n77LssXpql4
ARTICLE Brush Add Ons  https://www.makeuseof.com/tag/install-gimp-brushes/
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CLONE & HEALING

The clone and healing tools both have a source and a target.  Set the source by hovering over a location 
and then press the CTRL key on your keyboard and click the left mouse button.  The Healing tool 
copies and blends, while the Clone tool just copies pixels.  
VIDEO: Clone man out of Dog photo  3:33 https://www.youtube.com/watch?v=QeP-TvXDDl4
VIDEO: Cloning and Healing 6:53 https://www.youtube.com/watch?v=1_QgEa9SiBU

HEALING A SELECTION (RESYNTHESIZER )

Resythesizer is a GIMP plugin that automates removing an object from a picture.  We have the 
resynthesizer plug-in installed in the lab.  Select the object to be removed, including a little bit of the 
are that you want to be copied.  Then go to the Filters->Enhance->Heal Selection.  
VIDEO: Resynthesizer 10:07 https://www.youtube.com/watch?v=J61ExqvNcBQ

 BLUR SHARPEN

Use blur to blend colors.  Use blur to decrease the different
between colors.  Sharpen is supposed to increase the difference
between colors.   The tool can be toggled from blur to sharpen.
VIDEO: Blur an Owl 2:06
https://www.youtube.com/watch?v=UEMwRdOktIo

 SMUDGE

Blurring with direction, more or less a smear.
VIDEO: Smudge an Owl 1:02 https://www.youtube.com/watch?v=oOdpLNevDng

 DODGE/BURN(Lighten/Darken)

Scroll to the bottom of the dodge/burn tools options to see the
controls that apply.  The dodge tools works on a specific range of
tones, dark, mid, or light.  It lightens in Dodge mode, it darkens in
burn mode.
VIDEO: Dodge Burn 2:04
https://www.youtube.com/watch?v=B4C2TC_RjCs
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  COLOR TOOL

Just about every program you use to create content has a color tool.  The GIMP  color tool shows you 
the current foreground and background.  You can click on either the foreground color to change the 
color. Unlike some of the simpler color sectors you may see in other programs, this color tool allows 
you to select any of the 16.7 million colors.

The small icon in the upper right will swap 
foreground and background.

  

 COLOR PICKER

 The color picker takes the guess work out of color selection by just choosing a color from a specific 
pixel or the average color of a group of pixels. 

VIDEO: Color Picker 4:40 https://youtu.be/TistitcywFM 

 TEXT

Adding names to photos can be very helpful in identifying photos, and can also be easily removed from
a your final product. 

VIDEO: Text for Beginners 5:29 https://www.youtube.com/watch?v=LoPLBbNeedo
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COLORS  

RED EYE REMOVAL

Red eye in photos is easily corrected.  This option is found on the Filter Menu.
Filter ->Enahance ->Red Eye Removal
VIDEO:  Red Eye Removal 4:17 https://youtu.be/wzcoahp1UjA

FADED PHOTOS 

Badly faded photos still carry a surprising amount of data.  The best tool to fix a faded photo color 
levels tool.  Open the faded photo in GIMP and from the Colors menu and select Levels and then click 
on the Auto Input Level button.
VIDEO: Auto Levels 4:08  https://www.youtube.com/watch?v=ZhyvW-oa3Jk

In another, we see how to repair a partially faded picture using lightness and contrast.
VIDEO: Partial Faded Portion 12:15   https://www.youtube.com/watch?v=eeiETD0VVpQ

OTHER COLOR ADJUSTMENS

Gimp offers many other color correction tools, you can adjust levels, curves, exposure, hue, color 
balance, color saturation, there are many Auto settings like Equalize, White Balance, Stretch Contrast, 
Color Enhance that can improve your photos.  Each photo problem needs a custom solution.  Use some 
trial and error to see what changes you need.

RECOMENDED VIDEOS ON COLOR CORRECTION

VIDEO Girl in Yellow Hat 9:48  https://www.youtube.com/watch?v=DaeHrNt-Hrs
VIDEO Basic Color Settings 9:31 https://www.youtube.com/watch?v=hUXc-fOovak
VIDEO Advanced Colors 22:49    https://www.youtube.com/watch?v=TiavEWDVQGE
VIDEO Color Curves 13:57 https://www.youtube.com/watch?v=JDY6voINTso
VIDEO Luminosity to fix dark objects 22:11 https://www.youtube.com/watch?v=3Izcmh1ZB4U
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TRANSFORMATION TOOLS

On both the Image and Layer menus you have Transform menus that let you flip images horizontally,
vertically, rotate them 90º clockwise,  90º counter-clockwise, or 180º, but just about every image 
handling program can do that.  Photo programs let you do more interesting moves.

 Rotation Tool to straighten a photo.

Drag a horizontal guideline down from the top, or a vertical guideline from the left, then select the 
rotation tool.  Drag the image until the item is straight.  Adjust the clipping setting in the tools option 
box to determine what to do with the corners that overhang the the layer boundries/  Then press the 
Rotate button on the dialog box.  
VIDEO: Rotation with GIMP 9:14  https://youtu.be/sLAR7iotcIw

  
  Perspective Correction

This tool can square up an image.  This tool is particularly useful if you've taken a photograph of an 
image instead of using a scanner.  
VIDEO: Perspective tool 5:44 https://youtu.be/3vvKu36Vg8A 

  Scale

Right-sizing an image for emailing or for display on the web is important.  If an image is large it is 
going to take forever for the recipient to open the file, or the webpage to load.  There are two ways to 
reduce the number of bytes being sent.  One is to reduce the dimensions (pixels), the other is to reduce 
the quality when you Export the document.  
Hint: Use the Ctrl key while dragging the scale tool to keep the image ratio.  
VIDEO: Scaling an Image 2:14 https://www.youtube.com/watch?v=6DHxgkSG_Zw&t=0s

Cropping an image

Cropping, (cutting the edge off of photos)  is used to remove an unwanted irrelevant detail from a 
photo, change its aspect ratio, or to improve the overall composition.  Select the area with the cropping
tool, and then click inside the image. 

VIDEO: How to crop an image 1:56 https://www.youtube.com/watch?v=2QMAhaSWf3E
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LAYERS

As you get more into creating content, you'll need to have some understanding of layers.  You even 
need to understand layers to cut and paste.  

LAYER DIALOG

When working with layers it is very important to know which layer you are working on.  The dockable 
layer dialog box started life in the lower right hand corner of GIMP.  If it went missing you can call it 
back up using CTRL + L or from the menu Windows → Dockable Dialogs → Layers.  The layer that 
has focus is will be the rectangle that has a white box around it.  

Canvas – the area that is going to be included in our exported picture.

Think of building a collage, you are given a bunch of pictures to arrange in some artful way on a piece 
of paper or poster board, that would be your canvas.  The order that you the pictures on it would be 
your layers, and the finished product, everything on the canvas would be your image.  

Alpha Channel – Include transparency on a layer

When a layer has an alpha channel, it changes how the eraser tool and the delete of a selection works.  
If there is no alpha channel, the eraser just paints with the background color and delete fills the area 
with the background color.  If there is an alpha channel using the eraser or deleting a selection makes 
the area transparent any you can see through it to the layer below.  

VIDEO:  Circles 6:44 https://www.youtube.com/watch?v=v2ZE9oQH4YE
VIDEO:  Image vs Layer 5:21  https://www.youtube.com/watch?v=gwJP7sUaXeI
VIDEO:   Door, Clock, Dog  6:12 https://www.youtube.com/watch?v=v2ZE9oQH4YE
ARTICLE: https://www.lifewire.com/introduction-to-layer-groups-in-gimp-1701685
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Layer Masks

Layer masks are a fundamental tool in image manipulations. Masks allow you to selectively modify the
opacity (transparency) of the layer they belong to.  Masking differs from the use of the layer Opacity 
slider as a mask has the ability to selectively modify the opacity of different areas across a single layer.

Anything painted black on the layer mask will be transparent on the layer.
Anything painted white on the layer mask will be visible on the layer. 
Anything painted with other colors will have interesting effects on the transparency.

The reason we prefer masking to erasing directly from the photo, is that if you need to un-erase 
something, you can restore it by painting white on the layer mask, no matter how many other edits you 
did before you noticed that you goofed on your original erasure.  

You can add a mask to the selected layer, either by going to the menu
and selecting Layer →Mask →Add Mask or by clicking on the 
mask icon in the layer toolbox. 

When you add a layer mask you have several choices on how to 
initialize the mask.  The three I find most useful are:

A full white layer mask, so everything on the layer is visible.

A full black layer mask, so nothing on the layer is visible.

Selection mask, so only the selection will be visible on the layer. 

Layer masks are a complicated subject but getting your head around 
the basic concept opens up many more ways to enhance your photos

VIDEO: Thank You https://youtu.be/YMj2HCfSXys
VIDEO: Quick mask Cat 2:52  https://www.youtube.com/watch?v=OR2yOhKJdnU 
VIDEO: Partial Colored Duck 3:11 https://www.youtube.com/watch?v=qPMmfUNmsJM
VIDEO: Partial Colored Toys 4:14 https://www.youtube.com/watch?v=a7st18ZwlAY
VIDEO: Scald the bunny 8:11  https://www.youtube.com/watch?v=PI8_2FnIow0
VIDEO: Cutting out Hair 6:42  https://www.youtube.com/watch?v=AnbxtMCHKV0
VIDEO: Remove background  9:14 https://m.youtube.com/watch?v=FD8qqh3ySI4

Luminosity Mask 

ARTICLE: https://patdavid.net/2011/10/getting-around-in-gimp-luminosity-masks.html
VIDEO: Luminosity Mask 22.10 https://www.youtube.com/watch?v=3Izcmh1ZB4U

Vicky Getz page 17 of 21 Revised 03/26/23

https://youtu.be/YMj2HCfSXys
https://www.youtube.com/watch?v=3Izcmh1ZB4U
https://patdavid.net/2011/10/getting-around-in-gimp-luminosity-masks.html
https://m.youtube.com/watch?v=FD8qqh3ySI4
https://www.youtube.com/watch?v=AnbxtMCHKV0
https://www.youtube.com/watch?v=PI8_2FnIow0
https://www.youtube.com/watch?v=a7st18ZwlAY
https://www.youtube.com/watch?v=qPMmfUNmsJM
https://www.youtube.com/watch?v=OR2yOhKJdnU


GIMP 2.10.8

Layer Modes

Layer modes are also sometimes called “blending modes”. Selecting a layer mode changes the 
appearance of the layer or image, based on the layer or layers beneath it. If there is only one layer, the 
layer mode has no effect. There must therefore be at least two layers in the image to be able to use layer
modes. 

Gimp has 38 layer blending modes divided into 7 categories.

Normal (Normal, Dissolve, Erase, Color Erase, Merge and Split)

Lighten (Lighten only, Luma/Luminance, Screen, Dodge, Addition)

Darken (Darken only, Luma/Luminance. Multiply, Burn, Linear burn)

Contrast (Overlay, Soft light, Hard light, Vivid light, Pin light, Linear light, Hard mix)

Inversion (Difference, Exclusion, Subtract, Grain extract, Grain Merge, Divide)

HSV components (HSV Hue, HSV Saturation, HSL Color, HSV Value)

LCh components (LCh Hue, LCh Chroma, LCh Color, LCh Lightness, LCh Luminance)

An understanding of layer modes, helps you get better results out of GIMP, and its worth while 
watching this 1 hour long video.

VIDEO: Comprehensive look at layer modes 58:32 https://www.youtube.com/watch?v=17Iivi0tmug
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SHARPENING 

There are many ways to sharpen your images in GIMP.  We are going to look at 4 of them.  The first 
two are built in functions of GIMP.  The next 2 require adding plugins,.  See section on “How to Add a 
GIMP PlugIn” 

Filter → Enhance→ Sharpen (Unsharp Mask)

Click on this option, fiddle with the sliders until you get the results you want, and then save 
your results.  

VIDEO: Raspberries in the bowl 4:05 https://www.youtube.com/watch?v=fFZV4zT1fec     . 
VIDEO: Sharpen an Image 1:44 (music no description)

 https://www.youtube.com/watch?v=StNx2RJxbW4

Filter → Enhance→ High Pass

High pass filtering gives much better results than the Sharpen (Unsharp mask), but it is a little
more complicated because now you are dealing with layers.  

Old method:
1. Create a duplicate layer of the image.  This is not just for comparison!
2. Run Filter → Enhance→ High Pass, and adjust the Std. Dev. and Contrast settings to 

your liking.  
3. On the layer tab, change the Layer Mode type from Normal, to the desired blending 

mode.  Typically Grain Merge.  
4. Duplicate the layer, as necessary, to increase the effect.
5. When you like what you see, merge the layers , Image → Merge Visible layers

VIDEO: The Fly 4:06 https://www.youtube.com/watch?v=6AvIAgjQCFo 
VIDEO: Buttons https://www.youtube.com/watch?v=cYWOK5v_OuY
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GIMP 2.10.8

Filter → Enhance→ Wavelet-decompose

Wavelet decompose is a GIMP plugin.  You will need to download and install this tool 
separately.  

This tool makes a copy of your image and divides it into layers that can be worked on 
separately. This tool is very good for airbrushing faces while leaving the detail intact.  

Filter → G'MIC Qt → Details → Sharpen [ Octave Sharpening ]

The G'MIC Qt method requires a plugin.  

Video: https://www.youtube.com/watch?v=YjqMT7Mn2ac

DENOISE

There are two types of noise, color  and luminosity (white dots).  They make the picture look grainy.  
The methods for fixing this involve blurring the photos.

Filter → Enhance → Denoise

This method blurs the whole picture or a selection.  When used on the whole picture it generally
yields unacceptable quality.

Two step method using HSL and G'IMC Smoothing

This method requires the G'IMC Plugin.  It give much better results than a simple denoise

Reduce Color noise
Duplicate the layer
Filter → Blur → Gausian Blur until color noise disappears
Set Layer mode to HSL Color Mode to blend the colors with the layer below
Layer new from Visible

Remove Luminance noise with smoothing
Filter → G'MIC Qt → Repair → Smoothing
Try various settings 

   VIDEO: How to Easily Denoise Photos in GIMP  7:25      
https://www.youtube.com/watch?v=Ie4yrT0angI
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GIMP 2.10.8

COPY AND PASTE

Even Copy (Ctrl + C) and Paste (Ctrl + V) behave differently in GIMP.  When you paste a floating 
layer is created.  To finish pasting,  right click on the floating layer, and then choose  Anchor Layer or 
To New Layer depending on what you want to do with the paste.
VIDEO Copy and Paste 3:54  https://www.youtube.com/watch?v=18Kx9k66coY

TROUBLESHOOTING

Missing Controls and Panels
VIDEO https://www.youtube.com/watch?
v=MNRS_e4lsxU&t=0s&list=PLTNGHxWTtzJRdusrUb9BuZh0f95z6Ny7q&index=7

When Tools don't work
VIDEO https://www.youtube.com/watch?v=kDOhxuiQ7ZU

Hint If you can't get your clone and healing to sample an area try selecting the magnifying tool 
and zooming in, and zooming out CTRL and Zoom and then reselect the healing tool and try to 
get the sample.
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